Error Compress::Zlib al actualizar CentOS 4 con Plesk

Hoy me he encontrado con un curioso error al tratar de actualizar un CentOS 4.5 con Plesk 8.2 instalado y que hace uso de los repositorios de centos plus y atomic rocket turtle para disponer de las últimas versiones de PHP5 y Mysql5.

A tratar de actualizar los paquetes nuevos del sistema no permite actualizar PHP porque le falta perl-libwww-perl y este a su vez reporta este error:

Error: Missing Dependency: perl(Compress::Zlib) is needed by package perl-libwww-perl

Para solventar este problema solo tenéis que añadir al listado de repositorios en /etc/yum.repos.d/CentOS-Base.repo el repositorio fasttrack

[fasttrack]
name=CentOS-4 - fasttrack
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=fasttrack
#baseurl=http://mirror.centos.org/centos/$releasever/fasttrack/$basearch/
gpgcheck=1
enabled=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4

Una vez completados estos cambios ya puedes hacer un yum update para actualizar totalmente tu sistema CentOS con panel de control Plesk.

  • Jose Ignacio

    Gracias David…siempre al tanto de todo.

  • Marlon

    Gracias! Me ha servido de mucho!

    Slds.