Seguro que más de uno habéis tenido problemas con las extensiones para gestión de imágenes, conversión, y otras tantas utilidades relacionadas, en concreto GD e ImageMagick que funcionan tanto para PHP como para Perl.

Si tienes CentOS solo tienes que actualizarlo desde el repositorio de centosplus y te funcionará sin problemas.

Actualizar ImageMagick:

yum --enablerepo=centosplus install ImageMagic*

Actualizar GD:

yum --enablerepo=centosplus install gd-*

Espero que os sea de utilidad si tenéis problemas en un sistema con CentOS, tanto si tiene Plesk como sino lo tiene.