WordPress 3.2 más exigente con tu hosting web

Apenas nos quedas días para la salida de una versión con notables cambios del popular gestor CMS y blogs. WordPress 3.2 incorpora muchas e importantes novedades, y quizás las más destacada es el aumento de versiones requeridas. Aquí os dejamos un resumen que nos os pille de susto y podáis comprobar si vuestro hosting web es compatible.

Entre los requisitios de WordPress 3.2 en cuanto a servidor y recomendaciones de la iniciativa Browse Happy están:

  • Necesario PHP 5.2.4 o superior.
  • Necesario MySQL 5.0 o superior.
  • El módulo mod_rewrite de Apache pasa  a ser obligatorio, aunque ya podían pensar en la compatibilidad con nginx, lighttpd, …
  • Navegadores de Internet también hay cambios para la administración, recomendando Chrome 11, Firefox 4, Safari 5, Opera 11.10 o Internet Explorer 9 como mínimo.

¿Cómo podemos comprobar que versiones tenemos en nuestro hosting?

Comprueba la versiones que tiene tu servidor:

  • Comprobar la versión de PHP. Puedes hacerlo desde la información de proveedor, desde consola con con PHP -v, con un php con la función phpinfo o usar este comprobador.
  • Comprobar la versión de MySQL. Lo mismo consulta a tu proveedor, utilizar este plugin LAMP para comprobarlo o con el comando de terminal mysql –version.
  • Comprobar si tenemos instalado el módulo Apache mod_rewrite. La forma rápida y sencilla es con un .htaccess probar a ver si puedes ver las carpetas dentro de un directorio desde tu navegador. Introduce estas 2 líneas en un .htaccess:
    Options +FollowSymLinks
    RewriteEngine On
    Si no ves nada es que está instalado y si recibes un un Error 500 es que no.
  • Y por último la versión del navegador web. Desde la iniciativa Browse happy puedes acceder a la descarga de los principales navegadores en sus últimas versiones. Me estoy pensando si hacer una versión de la web en castellano.

Gracias a Fernando por estar siempre al tanto de estas cosas y por supuesto a WordPress. Si necesitas un hosting web compartido, vps linux o servidor dedicado os recomiendo hostalia.

  • Andy Garcia

    La recomendación de navegadores a la ultima versión de cada uno me parece correcta pero tengo entendido que el único que va a dejar de tener soporte es explorer 6 aunque eso no es una novedad importante ya que al viejo explorer ya ni su padre (microsoft) lo quiere, en fin…

  • Lo veo una medida positiva. No se puede ir tirando de versiones antiguas de php, apache, mysql y similares.
    Una medida para forzar el estar actualizados desde el punto de vista del hosting.

  • Dario Cedeno V

    Eso en cuanto a requerimientos, las ultimas versiones traen un mayor consumo de recursos de servicios tambien, consultas excesivas a la BD, tienes algún dato al respecto.??

    Saludos