El fin de PHP4, es hora de cambiar a PHP5

Parece que todavía son muchos los programadores que viven anclados en PHP4 y que no ven cuando dar un salto a la nueva versión de PHP, la versión 5, que aporta muchisimo más potencial de desarrollo y seguridad, y que por ejemplo en Ferca Network hace meses soportamos, aunque parece que otros proveedores no lo consideran interesante, no ofreciendo el nuevo PHP5.

GoPHP5

GoPHP5.org es un proyecto de la comunidad de PHP que ha decidido que es hora de mover ficha y han puesto como fecha tope el 5 de febrero de 2008 para que todo los programas Open Source en PHP exijan mínimo una configuración de PHP 5.2.0 o superior.

Según comentan parece que una de las razones de que muchos programadores y proveedores no actualicen sus PHP4 es que el nuevo PHP6 está de camino y podrían estar esperándolo, cuando sin duda es mejor aprovecharse ahora de las funciones y posibilidades de PHP5 y después cuando tengamos la versión 6 preparar lo que sea necesario para hacer correr nuestras aplicaciones.

Algunos proyectos que aún estaban en PHP4 se han unido a la iniciativa, y algunos ya están preparados para solo funcionar en PHP5 o superior.

Sitio Oficial: GoPHP5.org
vía: Digg

  • Santiago José López Borrazás

    Hola David:

    Yo aún tengo PHP4, a través de la Debian Etch.

    Aunque, tengo en los repositorios, el PHP5.

    En mi caso, por el momento, no tengo pensado poner el PHP4 tan temprano. Porque tengo internamente phpMyAdmin, que tengo la última versión, y sé que hay incompatibilidades aún. Lo tengo bajo user/password y protegido para no verlo por nadie. Ni siquiera, he dado el directorio de dónde está.

    Desde luego, que podría hablarte por privado algunas cuestiones técnicas sobre el PHP5. Pero bueno,…lo mirariamos con mucha más calma. ;-)

    En todo caso, es muy temprano para cambiarlo a la nueva versión. Ya sé que tiene implementadas nuevas funcionalidades, nuevas cosas y todo eso…pero bueno. 8-P

    Slds…

  • Santiago José López Borrazás

    Ah, dije el PHP4, me refería al PHP5.

    Slds…

  • Creo que el mayor problema, es que muchos hostings todavía usan PHP4 y por esa razón es que algunos CMS no han migrado a PHP5.

  • Y como no te animas a correr todo con PHP5, el 99% del código de PHP4 suele ser compatible con pequeños cambios :)

  • Santiago José López Borrazás

    Hola David:

    Je! En mi caso, por el momento, no voy a pasar a PHP5. Cuando tenga tiempo con otros proyectos, sí que lo haré. Pero mientras… ;-)

    Slds…