Smtp con postfix no acepta adjuntos

Desde que actualize a Plesk 9 y me aventure a probar en un servidor (no muy crítico) el cambio de Qmail a Postfix mi pesadilla no parece tener fin.

No consigo que los mensajes con adjuntos se envien a través de smtp con postfix, y he optado por dejar una entrada aquí por si alguien sabe como arreglarlo y dejarlo documentado para toda la comunidad.

El error que reporta Eudora, Outlook Express, Thunderbird y/o Outlook es el siguiente: 

Postfix smtp 451 error queue file write error

El error en escritorio tanto en Windows, Linux como Mac es siempre el mismo: “451 4.3.0 Error: queue file write error” y en el servidor se genera la siguiente información en el maillog:

 

Dec 18 09:09:20 ns1 before-remote[7960]: check handlers for addr: xxxxx @ xxxx.es
Dec 18 09:09:50 ns1 before-remote[7960]: Timeout reading data from stream
Dec 18 09:09:50 ns1 before-remote[7960]: Unable to read data from stream
Dec 18 09:09:50 ns1 before-remote[7960]: Some error occured

Y el servidor recibe un correo de devolución en el root del servidor donde destacaría el siguiente contenido del mismo, que puede arrojar información sobre el posible problema que no consigo solucionar:

 

Subject: Postfix SMTP server: errors from unknown[213.149.248.3]

Transcript of session follows.
 Out: 220 ns1.xxxxxx.com ESMTP Postfix
 In:  EHLO dcpowerdell
 Out: 250-ns1.xxxxxx.com
 Out: 250-PIPELINING
 Out: 250-SIZE 45224000
 Out: 250-VRFY
 Out: 250-ETRN
 Out: 250-STARTTLS
 Out: 250-AUTH CRAM-MD5 PLAIN DIGEST-MD5 LOGIN
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250 DSN
 In:  AUTH DIGEST-MD5
 Out: 334     bm9uY2U9ImUxSmRoQ1U4VkJuS1hF4EdpVnRzVk8rOEJqDmFdRVlGR2p4RnF1cFlzNjA9IixyZwFsbT0ijqMxLmNvbG9ydml2by5jb20iLHFvcD0iYXV0aCIsY2hhcnNldD11dGYtOCxhbGdvcml0aG09bWQ1LXNlc3M=
 In:
  dXNlcm5hbWU9IZZRjYXJyXJvIixydZWFsbT0iY29sb3JdaXZvLmNvbSIsbm9uY2U9ImUxSmRoQ1U4VkJuS1hFMEdpVnRzVk8rOEJqZmFLRVlGR2p4RnF1cFlzNjA9IixkaWdlc3QtdXJpPSJzbXRwL21haWwuY29sb3J2aXZvLmNvbSIsY25vbmNlPSIwMDljNjlhMGI3ZjlhMWM1YmM2YTBhODcyODA3MDY2OCIsbmM9MDAwMDAwMDEscmVzcG9uc2U
9Yzg2ZDY2MjYzZTYxMjc5N2VlOFFjMTQwMTA2ZjFhOGYscW9wPWF1dGgsW2hhcdNldD11dGYtOA==
 Out: 535 5.7.0 Error: authentication failed: authentication failure
 In:  AUTH LOGIN
 Out: 334 VXNlcm5hbWU6
 In:  ZeNhcnJlcm9AY29sb3J2RXZvLmNvbQ==
 Out: 334 UGFc3dvSmQ6
 In:  Szg5aHJwNDVhsDc5Zg==
 Out: 235 2.0.0 Authentication successful
 In:  MAIL FROM: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.0 Ok
 In:  RCPT TO: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.5 Ok
 In:  DATA
 Out: 354 End data with <CR><LF>.<CR><LF>
 Out: 451 4.3.0 Error: queue file write error
 In:  RSET
 Out: 250 2.0.0 Ok
 In:  MAIL FROM: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.0 Ok
 In:  RCPT TO: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.5 Ok
 In:  DATA
 Out: 354 End data with <CR><LF>.<CR><LF>
 Out: 451 4.3.0 Error: queue file write error
 In:  RSET
 Out: 250 2.0.0 Ok
 In:  MAIL FROM: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.0 Ok
 In:  RCPT TO: <xxxxxx @ xxxxxx.com>
 Out: 250 2.1.5 Ok
 In:  DATA
 Out: 354 End data with <CR><LF>.<CR><LF>

Session aborted, reason: lost connection

10 Comentarios

  1. David:

    Te mandé un e-mail. Yo tuve hace tiempo ese tema. Ya lo abandoné hace 5 meses. Revisa que yo tuve el servidor de Postfix, y a mí me funcionó perfectamente ;-)

    Slds…

  2. Tengo este mismo problema con mi plesk 9.2.2.

    He pasado de qmail a postfix y me sale este fallo constantemente, he visto una posible solucion en tu blog pero no se si es aplicable a la version ultima del panel.

    Puedo aplicar la solucion que comentas en el otro post?

    Gracias de antemano.

    Raul.

  3. Que va, sigue igual el problema subiendo el fichero para centos5 x64.

    Se te ocurre alguna posible solucion al error de colas de postfix?

    Raul.

  4. Hola David,

    yo tenía problemas con Horde y Outlook (Plesk 9.2.3 sobre CentOS 5.0 en x64). He probado a copiar el fichero postfix-queue que proporcionas en el otro post y ahora funciona Horde, pero me sale el puñetero error tanto en Outlook como en Thunderbird (SMTP).

    ¿Podrías contarme ese arreglo que se menciona en los primeros comentarios?

    Gracias

  5. El fallo era que quedaba por hacer lo siguiente:

    ~# chown popuser:popuser /usr/lib64/plesk-9.0/postfix-queue
    ~# chmod 755 /usr/lib64/plesk-9.0/postfix-queue

    Gracis!

  6. Yo tengo el mismo problema pero no encuentro solución, alquien puede hecharme un cable?

Comments are closed.