Actualizando a PHP 5.2.11

El pasado 17 de septiembre se liberó PHP 5.2.11 una versión que soluciona unos 75 errores y algunos problemas de seguridad. Todo dentro de la serie 5.2, ya que actualizar a PHP 5.3 es más complicado porque supone la posibilidad de tener que revisar código PHP para su correcto funcionamiento, aunque son mínimos los cambios.

Entre las correcciones de seguridad y errores solucionados en PHP 5.2.11 podemos cirtar:

  • Corregido la validación certificada en php_openssl_apply_verification_policy. (Ryan Sleevi, Ilia)
  • Corregido la comprobación para el indice de color en imagecolortransparent(). (Pierre)
  • Corregido el bug #44683 (popen crashes when an invalid mode is passed). (Pierre)

Puedes ver más información sobre PHP 5.2.11 en el anuncio de versión, y la lista completa de cambios disponibles en el ChangeLog.

Yo acabo de actualizar dos servidores en Plesk 9.2 y CentOS 5.3 a 64 bits sin problemas, están funcionando correctamente las aplicaciones PHP propias y también algunas conocidas como OpenX, WordPress, …

  • Willy

    Hola, estoy buscando desde hace tiempo actualizar a PHP 5.2 en mi Plesk 9.2.2, tengo CentOS 5.3 i386 por favor pueden indicarme el repositorio a usar para instalar los RPMs de PHP 5.2? te agradezco